Fizz VPN - Netherlands #2 Low network speed – Incident details

Netherlands #2 Low network speed

Resolved
Degraded performance
Started about 1 month agoLasted 1 day

Affected

Nodes

Degraded performance from 11:11 AM to 4:24 PM

Netherlands #2

Degraded performance from 11:11 AM to 4:24 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Netowork issues. We recommend switching to other servers.

  • Investigating
    Investigating
    There could be short disconnections, bad latency times (more than 2000ms) and very low speed. We are currently looking into this issue.