Fizz VPN - Finland #1 Network Issues – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
All systems operational
Finland #1 Network Issues
Resolved
Degraded performance
Started about 1 month ago
Lasted about 11 hours
Affected
Nodes
Degraded performance from 6:15 AM to 4:50 PM
Finland #1
Degraded performance from 6:15 AM to 4:50 PM
Updates
Resolved
July 18, 2025 at 4:50 PM
Resolved
July 18, 2025 at 4:50 PM
This incident has been resolved.
Identified
July 18, 2025 at 11:23 AM
Identified
July 18, 2025 at 11:23 AM
We are still waiting for a fix from hotsing provider.
Investigating
July 18, 2025 at 6:15 AM
Investigating
July 18, 2025 at 6:15 AM
There could be short disconnections and bad latency times (more than 2000ms). We are currently looking into this issue.